- Table of Contents
-
- H3C S12500R Ethernet Switch Router Series Config Examples-Release 36xx-6W100
- 01-Login Management Configuration Examples
- 02-RBAC Configuration Examples
- 03-Software Upgrade Examples
- 04-Ethernet Link Aggregation Configuration Examples
- 05-Port Isolation Configuration Examples
- 06-Spanning Tree Configuration Examples
- 07-VLAN Configuration Examples
- 08-VLAN Tagging Configuration Examples
- 09-DHCP Snooping Configuration Examples
- 10-Cross-Subnet Dynamic IP Address Allocation Configuration Examples
- 11-IPv6 over IPv4 Tunneling with OSPFv3 Configuration Examples
- 12-GRE Tunnel Configuration Examples
- 13-GRE with OSPF Configuration Examples
- 14-OSPF Configuration Examples
- 15-IS-IS Configuration Examples
- 16-BGP Configuration Examples
- 17-Policy-Based Routing Configuration Examples
- 18-OSPFv3 Configuration Examples
- 19-IPv6 IS-IS Configuration Examples
- 20-Routing Policy Configuration Examples
- 21-IGMP Snooping Configuration Examples
- 22-IGMP Configuration Examples
- 23-MLD Snooping Configuration Examples
- 24-Basic MPLS Configuration Examples
- 25-MPLS L3VPN Configuration Examples
- 26-ACL Configuration Examples
- 27-Control Plane-Based QoS Policy Configuration Examples
- 28-Traffic Policing Configuration Examples
- 29-GTS and Rate Limiting Configuration Examples
- 30-Priority Mapping and Queue Scheduling Configuration Examples
- 31-Traffic Filtering Configuration Examples
- 32-AAA Configuration Examples
- 33-SSH Configuration Examples
- 34-IP Source Guard Configuration Examples
- 35-Ethernet OAM Configuration Examples
- 36-CFD Configuration Examples
- 37-DLDP Configuration Examples
- 38-VRRP Configuration Examples
- 39-BFD Configuration Examples
- 40-NTP Configuration Examples
- 41-SNMP Configuration Examples
- 42-NQA Configuration Examples
- 43-Mirroring Configuration Examples
- 44-sFlow Configuration Examples
- 45-OpenFlow Configuration Examples
- 46-MAC Address Table Configuration Examples
- 47-Static Multicast MAC Address Entry Configuration Examples
- 48-IP Unnumbered Configuration Examples
- 49-Congestion Avoidance and Queue Scheduling Configuration Examples
- 50-Attack Protection Configuration Examples
- 51-Smart Link Configuration Examples
- 52-RRPP Configuration Examples
- 53-BGP Route Selection Configuration Examples
- 54-IS-IS Route Summarization Configuration Examples
- 55-MPLS OAM Configuration Examples
- 56-MPLS TE Configuration Examples
- 57-VXLAN Configuration Examples
- 58-NetStream Configuration Examples
- 59-EVPN-DCI over an MPLS L3VPN Network Configuration Examples
- 60-PTP Configuration Examples
- 61-S-MLAG Configuration Examples
- 62-MPLS SR Configuration Examples
- 63-Puppet Configuration Examples
- Related Documents
-
Title | Size | Download |
---|---|---|
11-IPv6 over IPv4 Tunneling with OSPFv3 Configuration Examples | 115.03 KB |
|
H3C S12500R Switch Router Series |
IPv6 over IPv4 Tunneling with OSPFv3 Configuration Examples |
|
Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.
No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.
Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.
The information in this document is subject to change without notice.
Contents
Example: Configuring IPv6 over IPv4 tunneling with OSPFv3
Configuring IPv6 over IPv4 tunnels
Introduction
This document provides IPv6 over IPv4 tunneling with OSPFv3 configuration examples.
Prerequisites
The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.
This document assumes that you have basic knowledge of IPv6 over IPv4 tunneling and OSPFv3.
Example: Configuring IPv6 over IPv4 tunneling with OSPFv3
Network configuration
As shown in Figure 1, in IPv6 networks, Device A, Device B, and Device C act as the gateways of the headquarters, Branch 1, and Branch 2, respectively.
Configure IPv6 over IPv4 tunnels to ensure that the headquarters can communicate with the two branches over IPv4 networks.
Configure OSPFv3 on the gateways to ensure the following:
· The gateways have routes to destination IPv6 addresses through tunnel interfaces.
· Branch 1 and Branch 2 can communicate with each other through the headquarters.
Table 1 Interface and IP address assignment
Device |
Interface |
IP address |
Device A |
HGE1/0/1 |
20.1.1.1/24 |
|
HGE1/0/2 |
2001::1/64 |
|
Tunnel1 |
3001::1/64 |
|
Tunnel2 |
4001::1/64 |
Device B |
HGE1/0/1 |
30.1.1.1/24 |
|
HGE1/0/2 |
5001::1/64 |
|
Tunnel1 |
3001::2/64 |
Device C |
HGE1/0/1 |
40.1.1.1/24 |
|
HGE1/0/2 |
6001::1/64 |
|
Tunnel2 |
4001::2/64 |
Software versions used
This configuration example was created and verified on Release 3606.
Restrictions and guidelines
For tunnel interfaces to send and receive packets, you must configure a tunnel-type service loopback group.
On the device, a tunneled packet cannot be directly routed based on its destination address. It is sent to a tunnel-type service loopback group, which then delivers the packet to the forwarding module for Layer 3 forwarding.
By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.
Procedures
Make sure the gateways can reach each other at IPv4.
Configuring IPv6 over IPv4 tunnels
· Configure Device A:
# Configure an IP address for HundredGigE 1/0/1.
<DeviceA> system-view
[DeviceA] interface hundredgige 1/0/1
[DeviceA-HundredGigE1/0/1] ip address 20.1.1.1 24
[DeviceA-HundredGigE1/0/1] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Create service loopback group 1, and specify its service type as tunnel.
[DeviceA] service-loopback group 1 type tunnel
# Assign HundredGigE 1/0/3 to service loopback group 1.
[DeviceA] interface hundredgige 1/0/3
[DeviceA-HundredGigE1/0/3] port link-mode bridge
[DeviceA-HundredGigE1/0/3] port service-loopback group 1
[DeviceA-HundredGigE1/0/3] quit
# Configure an IPv6 over IPv4 tunnel interface Tunnel 1.
[DeviceA] interface tunnel 1 mode ipv6-ipv4
# Configure an IPv6 address for Tunnel 1.
[DeviceA-Tunnel1] ipv6 address 3001::1/64
# Specify HundredGigE 1/0/1 as the source interface of Tunnel 1.
[DeviceA-Tunnel1] source hundredgige 1/0/1
# Specify the destination address for Tunnel 1.
[DeviceA-Tunnel1] destination 30.1.1.1
[DeviceA-Tunnel1] quit
# Configure an IPv6 over IPv4 tunnel interface Tunnel 2.
[DeviceA] interface tunnel 2 mode ipv6-ipv4
# Configure an IPv6 address for Tunnel 2.
[DeviceA-Tunnel2] ipv6 address 4001::1/64
# Specify HundredGigE 1/0/1 as the source interface of Tunnel 2.
[DeviceA-Tunnel2] source hundredgige 1/0/1
# Specify the destination address for Tunnel 2.
[DeviceA-Tunnel2] destination 40.1.1.1
[DeviceA-Tunnel2] quit
· Configure Device B:
# Configure an IP address for HundredGigE 1/0/1.
<DeviceB> system-view
[DeviceB] interface hundredgige 1/0/1
[DeviceB-HundredGigE1/0/1] ip address 30.1.1.1 24
[DeviceB-HundredGigE1/0/1] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Create service loopback group 1, and specify its service type as tunnel.
[DeviceB] service-loopback group 1 type tunnel
# Assign HundredGigE 1/0/3 to service loopback group 1.
[DeviceB] interface hundredgige 1/0/3
[DeviceB-HundredGigE1/0/3] port link-mode bridge
[DeviceB-HundredGigE1/0/3] port service-loopback group 1
[DeviceB-HundredGigE1/0/3] quit
# Configure an IPv6 over IPv4 tunnel interface Tunnel 1.
[DeviceB] interface tunnel 1 mode ipv6-ipv4
# Configure an IPv6 address for Tunnel 1.
[DeviceB-Tunnel1] ipv6 address 3001::2/64
# Specify HundredGigE 1/0/1 as the source interface of Tunnel 1.
[DeviceB-Tunnel1] source hundredgige 1/0/1
# Specify the destination address for Tunnel 1.
[DeviceB-Tunnel1] destination 20.1.1.1
[DeviceB-Tunnel1] quit
· Configure Device C:
# Configure an IP address for HundredGigE 1/0/1.
<DeviceC> system-view
[DeviceC] interface hundredgige 1/0/1
[DeviceC-HundredGigE1/0/1] ip address 40.1.1.1 24
[DeviceC-HundredGigE1/0/1] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Create service loopback group 1, and specify its service type as tunnel.
[DeviceC] service-loopback group 1 type tunnel
# Assign HundredGigE 1/0/3 to service loopback group 1.
[DeviceC] interface hundredgige 1/0/3
[DeviceC-HundredGigE1/0/3] port link-mode bridge
[DeviceC-HundredGigE1/0/3] port service-loopback group 1
[DeviceC-HundredGigE1/0/3] quit
# Configure an IPv6 over IPv4 tunnel interface Tunnel 2.
[DeviceC] interface tunnel 2 mode ipv6-ipv4
# Configure an IPv6 address for Tunnel 2.
[DeviceC-Tunnel2] ipv6 address 4001::2/64
# Specify HundredGigE 1/0/1 as the source interface of Tunnel 2.
[DeviceC-Tunnel2] source hundredgige 1/0/1
# Specify the destination address for Tunnel 2.
[DeviceC-Tunnel2] destination 20.1.1.1
[DeviceC-Tunnel2] quit
Configuring OSPFv3
· Configure Device A:
# Specify the router ID as 1.1.1.1.
[DeviceA] ospfv3
[DeviceA-ospfv3-1] router-id 1.1.1.1
[DeviceA-ospfv3-1] quit
# Enable OSPFv3 on Tunnel 1.
[DeviceA] interface Tunnel 1
[DeviceA-Tunnel1] ospfv3 1 area 0
[DeviceA-Tunnel1] quit
# Enable OSPFv3 on Tunnel 2.
[DeviceA] interface Tunnel 2
[DeviceA-Tunnel2] ospfv3 1 area 0
[DeviceA-Tunnel2] quit
# Enable OSPFv3 on HundredGigE 1/0/2.
[DeviceA] interface hundredgige 1/0/2
[DeviceA-HundredGigE1/0/2] ospfv3 1 area 0
[DeviceA-HundredGigE1/0/2] quit
· Configure Device B:
# Specify the router ID as 2.2.2.2.
[DeviceB] ospfv3
[DeviceB-ospfv3-1] router-id 2.2.2.2
[DeviceB-ospfv3-1] quit
# Enable OSPFv3 on Tunnel 1.
[DeviceB] interface Tunnel 1
[DeviceB-Tunnel1] ospfv3 1 area 0
[DeviceB-Tunnel1] quit
# Enable OSPFv3 on HundredGigE 1/0/2.
[DeviceB] interface hundredgige 1/0/2
[DeviceB-HundredGigE1/0/2] ospfv3 1 area 0
[DeviceB-HundredGigE1/0/2] quit
· Configure Device C:
# Specify the router ID as 3.3.3.3.
[DeviceC] ospfv3
[DeviceC-ospfv3-1] router-id 3.3.3.3
[DeviceC-ospfv3-1] quit
# Enable OSPFv3 on Tunnel 2.
[DeviceC] interface Tunnel 2
[DeviceC-Tunnel2] ospfv3 1 area 0
[DeviceC-Tunnel2] quit
# Enable OSPFv3 on HundredGigE 1/0/2.
[DeviceC] interface hundredgige 1/0/2
[DeviceC-HundredGigE1/0/2] ospfv3 1 area 0
[DeviceC-HundredGigE1/0/2] quit
Verifying the configuration
# Ping PC 1 from PC 2.
Pinging 2001::3
from 5001::3 with 32 bytes of data:
Reply from 2001::3: bytes=32 time=13ms
Reply from 2001::3: bytes=32 time=1ms
Reply from 2001::3: bytes=32 time=1ms
Reply from 2001::3: bytes=32 time<1ms
Ping statistics for 2001::3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 13ms, Average = 3ms
The output shows that the ping operation succeeds.
# Ping PC 3 from PC 2.
D:\>ping6 -s 5001::3 6001::3
Pinging 6001::3
from 6001::3 with 32 bytes of data:
Reply from 6001::3: bytes=32 time=13ms
Reply from 6001::3: bytes=32 time=1ms
Reply from 6001::3: bytes=32 time=1ms
Reply from 6001::3: bytes=32 time<1ms
Ping statistics for 6001::3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 13ms, Average = 3ms
The output shows that the ping operation succeeds.
Configuration files
· Device A:
#
service-loopback group 1 type tunnel
#
ospfv3 1
router-id 1.1.1.1
area 0.0.0.0
#
interface HundredGigE1/0/1
ip address 20.1.1.1 255.255.255.0
#
interface HundredGigE1/0/2
ospfv3 1 area 0.0.0.0
ipv6 address 2001::1/64
#
interface HundredGigE1/0/3
port link-mode bridge
port service-loopback group 1
#
interface Tunnel1 mode ipv6-ipv4
ospfv3 1 area 0.0.0.0
source HundredGigE1/0/1
destination 30.1.1.1
ipv6 address 3001::1/64
#
interface Tunnel2 mode ipv6-ipv4
ospfv3 1 area 0.0.0.0
source HundredGigE1/0/1
destination 40.1.1.1
ipv6 address 4001::1/64
#
· Device B:
#
service-loopback group 1 type tunnel
#
ospfv3 1
router-id 2.2.2.2
area 0.0.0.0
#
interface HundredGigE1/0/1
ip address 30.1.1.1 255.255.255.0
#
interface HundredGigE1/0/2
ospfv3 1 area 0.0.0.0
ipv6 address 5001::1/64
#
interface HundredGigE1/0/3
port link-mode bridge
port service-loopback group 1
#
interface Tunnel1 mode ipv6-ipv4
ospfv3 1 area 0.0.0.0
source HundredGigE1/0/1
destination 20.1.1.1
ipv6 address 3001::2/64
#
· Device C:
#
service-loopback group 1 type tunnel
#
ospfv3 1
router-id 3.3.3.3
area 0.0.0.0
#
interface HundredGigE1/0/1
ip address 40.1.1.1 255.255.255.0
#
interface HundredGigE1/0/2
ospfv3 1 area 0.0.0.0
ipv6 address 6001::1/64
#
interface HundredGigE1/0/3
port link-mode bridge
port service-loopback group 1
#
interface Tunnel2 mode ipv6-ipv4
ospfv3 1 area 0.0.0.0
source HundredGigE1/0/1
destination 20.1.1.1
ipv6 address 4001::2/64
#
Related documentation
· H3C S12500R Switch Router Series Layer 3—IP Routing Command Reference-R3606
· H3C S12500R Switch Router Series Layer 3—IP Routing Configuration Guide-R3606
· H3C S12500R Switch Router Series Layer 3—IP Services Command Reference-R3606
· H3C S12500R Switch Router Series Layer 3—IP Services Configuration Guide-R3606