- Table of Contents
-
- H3C S12500R Ethernet Switch Router Series Config Examples-Release 36xx-6W100
- 01-Login Management Configuration Examples
- 02-RBAC Configuration Examples
- 03-Software Upgrade Examples
- 04-Ethernet Link Aggregation Configuration Examples
- 05-Port Isolation Configuration Examples
- 06-Spanning Tree Configuration Examples
- 07-VLAN Configuration Examples
- 08-VLAN Tagging Configuration Examples
- 09-DHCP Snooping Configuration Examples
- 10-Cross-Subnet Dynamic IP Address Allocation Configuration Examples
- 11-IPv6 over IPv4 Tunneling with OSPFv3 Configuration Examples
- 12-GRE Tunnel Configuration Examples
- 13-GRE with OSPF Configuration Examples
- 14-OSPF Configuration Examples
- 15-IS-IS Configuration Examples
- 16-BGP Configuration Examples
- 17-Policy-Based Routing Configuration Examples
- 18-OSPFv3 Configuration Examples
- 19-IPv6 IS-IS Configuration Examples
- 20-Routing Policy Configuration Examples
- 21-IGMP Snooping Configuration Examples
- 22-IGMP Configuration Examples
- 23-MLD Snooping Configuration Examples
- 24-Basic MPLS Configuration Examples
- 25-MPLS L3VPN Configuration Examples
- 26-ACL Configuration Examples
- 27-Control Plane-Based QoS Policy Configuration Examples
- 28-Traffic Policing Configuration Examples
- 29-GTS and Rate Limiting Configuration Examples
- 30-Priority Mapping and Queue Scheduling Configuration Examples
- 31-Traffic Filtering Configuration Examples
- 32-AAA Configuration Examples
- 33-SSH Configuration Examples
- 34-IP Source Guard Configuration Examples
- 35-Ethernet OAM Configuration Examples
- 36-CFD Configuration Examples
- 37-DLDP Configuration Examples
- 38-VRRP Configuration Examples
- 39-BFD Configuration Examples
- 40-NTP Configuration Examples
- 41-SNMP Configuration Examples
- 42-NQA Configuration Examples
- 43-Mirroring Configuration Examples
- 44-sFlow Configuration Examples
- 45-OpenFlow Configuration Examples
- 46-MAC Address Table Configuration Examples
- 47-Static Multicast MAC Address Entry Configuration Examples
- 48-IP Unnumbered Configuration Examples
- 49-Congestion Avoidance and Queue Scheduling Configuration Examples
- 50-Attack Protection Configuration Examples
- 51-Smart Link Configuration Examples
- 52-RRPP Configuration Examples
- 53-BGP Route Selection Configuration Examples
- 54-IS-IS Route Summarization Configuration Examples
- 55-MPLS OAM Configuration Examples
- 56-MPLS TE Configuration Examples
- 57-VXLAN Configuration Examples
- 58-NetStream Configuration Examples
- 59-EVPN-DCI over an MPLS L3VPN Network Configuration Examples
- 60-PTP Configuration Examples
- 61-S-MLAG Configuration Examples
- 62-MPLS SR Configuration Examples
- 63-Puppet Configuration Examples
- Related Documents
-
Title | Size | Download |
---|---|---|
48-IP Unnumbered Configuration Examples | 77.41 KB |
|
H3C S12500R Switch Router Series |
IP Unnumbered Configuration Examples |
|
Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.
No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.
Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.
The information in this document is subject to change without notice.
Introduction
This document provides IP unnumbered configuration examples.
This feature enables an interface to borrow an IP address from another interface on the device when the borrowing interface does not have any IP addresses. The borrowing interface is called IP unnumbered interface.
Prerequisites
The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.
This document assumes that you have basic knowledge of IP unnumbered.
Restrictions and guidelines
When you configure IP unnumbered, follow these restrictions and guidelines:
· Loopback interfaces cannot borrow IP addresses of other interfaces.
· An interface cannot borrow an IP address from an unnumbered interface.
Example: Configuring IP unnumbered
Network configuration
As shown in Figure 1, Group A and Group B are two private IPv4 networks. Device A and Device C will establish a GRE tunnel to interconnect Group 1 and Group 2.
To save IP address space, configure tunnel interface Tunnel 1 to borrow an IP address from the loopback interface loopback 0.
Software versions used
This configuration example was created and verified on Release 3606.
Restrictions and guidelines
· By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable the interface.
· By default, interfaces on the device operate in Layer 3 mode. To configure an IP address for a Layer 2 interface, first execute the port link-mode route command in interface view to change the interface link mode to Layer 3.
Procedures
Configuring Device A
1. Assign IP addresses to the interfaces:
# Assign IP addresses to HundredGigE 1/0/1 and loopback 0.
<DeviceA> system-view
[DeviceA] interface hundredgige 1/0/1
[DeviceA-HundredGigE1/0/1] ip address 12.12.12.1 24
[DeviceA-HundredGigE1/0/1] quit
[DeviceA] interface loopback 0
[DeviceA-LoopBack0] ip address 8.8.8.8 32
[DeviceA-LoopBack0] quit
# Assign IP addresses to other interfaces in the same way an IP address is assigned to HundredGigE 1/0/1. (Details not shown.)
2. Configure OSPF:
[DeviceA] ospf 1
# Create Area 0 and specify HundredGigE 1/0/1 whose IP address is on network 12.12.12.0/24 to run OSPF in Area 0.
[DeviceA-ospf-1] area 0
[DeviceA-ospf-1-area-0.0.0.0] network 12.12.12.0 0.0.0.255
[DeviceA-ospf-1-area-0.0.0.0] quit
[DeviceA-ospf-1] quit
3. Configure a GRE tunnel:
# Create service loopback group 1 and specify the unicast tunnel service for the group.
[DeviceA] service-loopback group 1 type tunnel
# Assign HundredGigE 1/0/3 to the service loopback group.
[DeviceA] interface hundredgige 1/0/3
[DeviceA-HundredGigE1/0/3] port service-loopback group 1
[DeviceA-HundredGigE1/0/3] quit
# Create a tunnel interface Tunnel 1, and specify the tunnel mode as GRE/IPv4.
[DeviceA] interface tunnel 1 mode gre
# Specify 12.12.12.1 as the source address of interface Tunnel 1.
[DeviceA-Tunnel1] source 12.12.12.1
# Specify 23.23.23.3 as the destination address of interface Tunnel 1.
[DeviceA-Tunnel1] destination 23.23.23.3
# Configure interface Tunnel 1 to borrow an IP address from loopback 0.
[DeviceA-Tunnel1] ip address unnumbered interface loopback 0
[DeviceA-Tunnel1] quit
# Configure a static route from Device A through the tunnel interface to Group B.
[DeviceA] ip route-static 10.2.1.0 255.255.255.0 tunnel 1
Configuring Device B
1. Assign IP addresses to the interfaces:
# Assign an IP address to HundredGigE 1/0/1.
<DeviceB> system-view
[DeviceB] interface hundredgige 1/0/1
[DeviceB-HundredGigE1/0/1] ip address 12.12.12.2 24
[DeviceB-HundredGigE1/0/1] quit
# Assign an IP address to HundredGigE 1/0/2 in the same way an IP address is assigned to HundredGigE 1/0/1. (Details not shown.)
2. Configure OSPF:
# Enable OSPF process 1.
[DeviceB] ospf 1
# Create Area 0 and specify HundredGigE 1/0/1 whose IP address is on network 12.12.12.0/24 to run OSPF in Area 0.
[DeviceB-ospf-1] area 0
[DeviceB-ospf-1-area-0.0.0.0] network 12.12.12.0 0.0.0.255
# Create Area 0 and specify HundredGigE 1/0/2 whose IP address is on network 23.23.23.0/24 to run OSPF in Area 0.
[DeviceB-ospf-1-area-0.0.0.0] network 23.23.23.0 0.0.0.255
[DeviceB-ospf-1-area-0.0.0.0] quit
[DeviceB-ospf-1] quit
Configuring Device C
1. Assign IP addresses to the interfaces:
# Assign IP addresses to HundredGigE 1/0/1 and loopback 0.
<DeviceC> system-view
[DeviceC] interface hundredgige 1/0/1
[DeviceC-HundredGigE1/0/1] ip address 23.23.23.3 24
[DeviceC-HundredGigE1/0/1] quit
[DeviceC] interface loopback 0
[DeviceC-LoopBack0] ip address 9.9.9.9 32
[DeviceC-LoopBack0] quit
# Assign IP addresses to other interfaces in the same way an IP address is assigned to HundredGigE 1/0/1. (Details not shown.)
2. Configure OSPF:
# Enable OSPF process 1.
[DeviceC] ospf 1
# Create Area 0 and specify HundredGigE 1/0/1 whose IP address is on network 23.23.23.0/24 to run OSPF in Area 0.
[DeviceC-ospf-1] area 0
[DeviceC-ospf-1-area-0.0.0.0] network 23.23.23.0 0.0.0.255
[DeviceC-ospf-1-area-0.0.0.0] quit
[DeviceC-ospf-1] quit
3. Configure a GRE tunnel:
# Create service loopback group 1 and specify the unicast tunnel service for the group.
[DeviceC] service-loopback group 1 type tunnel
# Assign HundredGigE 1/0/3 to the service loopback group.
[DeviceC] interface hundredgige 1/0/3
[DeviceC-HundredGigE1/0/3] port service-loopback group 1
[DeviceC-HundredGigE1/0/3] quit
# Create a tunnel interface Tunnel 1, and specify the tunnel mode as GRE/IPv4.
[DeviceC] interface tunnel 1 mode gre
# Specify 23.23.23.3 as the source address of interface Tunnel 1.
[DeviceC-Tunnel1] source 23.23.23.3
# Specify 12.12.12.1 as the destination address of interface Tunnel 1.
[DeviceC-Tunnel1] destination 12.12.12.1
# Configure interface Tunnel 1 to borrow an IP address from loopback 0.
[DeviceC-Tunnel1] ip address unnumbered interface loopback 0
[DeviceC-Tunnel1] quit
# Configure a static route from Device C through the tunnel interface to Group A.
[DeviceC] ip route-static 10.1.1.0 255.255.255.0 tunnel 1
Verifying the configuration
This example uses Device A to verify the configuration.
# Verify that the interface Tunnel 1 has borrowed the IP address 8.8.8.8/32 from loopback 0.
[DeviceA] display interface tunnel 1
Tunnel1
Current state: UP
Line protocol state: UP
Description: Tunnel1 Interface
Bandwidth: 64kbps
Maximum transmission unit: 1476
Internet Address: 8.8.8.8/32 (Unnumbered)
Tunnel source 12.12.12.1, destination 23.23.23.3
Tunnel keepalive disabled
Tunnel TTL 255
Tunnel protocol/transport GRE/IP
GRE key disabled
Checksumming of GRE packets disabled
Last clearing of counters: Never
Last 300 seconds input rate: 0 bytes/sec, 0 bits/sec, 0 packets/sec
Last 300 seconds output rate: 0 bytes/sec, 0 bits/sec, 0 packets/sec
Input: 11 packets, 924 bytes, 0 drops
Output: 10 packets, 840 bytes, 0 drops
# Verify that HundredGigE 1/0/2 on Device A can ping the IP address of HundredGigE 1/0/2 on Device C.
# Verify that VLAN-interface 10 on Device A can ping the IP address of VLAN-interface 10 on Device C.
[DeviceA] ping -a 10.1.1.1 10.2.1.1
Ping 10.2.1.1 (10.2.1.1) from 10.1.1.1: 56 data bytes, press CTRL_C to break
56 bytes from 10.2.1.1: icmp_seq=0 ttl=255 time=32.641 ms
56 bytes from 10.2.1.1: icmp_seq=1 ttl=255 time=4.881 ms
56 bytes from 10.2.1.1: icmp_seq=2 ttl=255 time=4.816 ms
56 bytes from 10.2.1.1: icmp_seq=3 ttl=255 time=26.393 ms
56 bytes from 10.2.1.1: icmp_seq=4 ttl=255 time=43.003 ms
--- Ping statistics for 10.2.1.1 ---
5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 4.816/22.347/43.003/15.241 ms
Configuration files
· Device A:
#
service-loopback group 1 type tunnel
#
ospf 1
area 0.0.0.0
network 12.12.12.0 0.0.0.255
#
interface LoopBack0
ip address 8.8.8.8 255.255.255.255
#
interface HundredGigE1/0/1
ip address 12.12.12.1 255.255.255.0
#
interface HundredGigE1/0/2
ip address 10.1.1.1 255.255.255.0
#
interface HundredGigE1/0/3
port link-mode bridge
port service-loopback group 1
#
interface Tunnel1 mode gre
ip address unnumbered interface LoopBack0
source 12.12.12.1
destination 23.23.23.3
#
ip route-static 10.2.1.0 24 Tunnel1
#
· Device B:
#
ospf 1
area 0.0.0.0
network 12.12.12.0 0.0.0.255
network 23.23.23.0 0.0.0.255
#
interface HundredGigE1/0/1
ip address 12.12.12.2 255.255.255.0
#
interface HundredGigE1/0/2
ip address 23.23.23.2 255.255.255.0
#
· Device C:
#
service-loopback group 1 type tunnel
#
ospf 1
area 0.0.0.0
network 23.23.23.0 0.0.0.255
#
interface LoopBack0
ip address 9.9.9.9 255.255.255.255
#
interface HundredGigE1/0/1
ip address 23.23.23.3 255.255.255.0
#
interface HundredGigE1/0/2
ip address 10.2.1.1 255.255.255.0
#
interface HundredGigE1/0/3
port link-mode bridge
port service-loopback group 1
#
interface Tunnel1 mode gre
ip address unnumbered interface LoopBack0
source 23.23.23.3
destination 12.12.12.1
#
ip route-static 10.1.1.0 24 Tunnel1
#
Related documentation
· H3C S12500R Switch Router Series Layer 3—IP Services Command Reference-R3606
· H3C S12500R Switch Router Series Layer 3—IP Services Configuration Guide-R3606