- Table of Contents
-
- H3C S12500R Ethernet Switch Router Series Config Examples-Release 36xx-6W100
- 01-Login Management Configuration Examples
- 02-RBAC Configuration Examples
- 03-Software Upgrade Examples
- 04-Ethernet Link Aggregation Configuration Examples
- 05-Port Isolation Configuration Examples
- 06-Spanning Tree Configuration Examples
- 07-VLAN Configuration Examples
- 08-VLAN Tagging Configuration Examples
- 09-DHCP Snooping Configuration Examples
- 10-Cross-Subnet Dynamic IP Address Allocation Configuration Examples
- 11-IPv6 over IPv4 Tunneling with OSPFv3 Configuration Examples
- 12-GRE Tunnel Configuration Examples
- 13-GRE with OSPF Configuration Examples
- 14-OSPF Configuration Examples
- 15-IS-IS Configuration Examples
- 16-BGP Configuration Examples
- 17-Policy-Based Routing Configuration Examples
- 18-OSPFv3 Configuration Examples
- 19-IPv6 IS-IS Configuration Examples
- 20-Routing Policy Configuration Examples
- 21-IGMP Snooping Configuration Examples
- 22-IGMP Configuration Examples
- 23-MLD Snooping Configuration Examples
- 24-Basic MPLS Configuration Examples
- 25-MPLS L3VPN Configuration Examples
- 26-ACL Configuration Examples
- 27-Control Plane-Based QoS Policy Configuration Examples
- 28-Traffic Policing Configuration Examples
- 29-GTS and Rate Limiting Configuration Examples
- 30-Priority Mapping and Queue Scheduling Configuration Examples
- 31-Traffic Filtering Configuration Examples
- 32-AAA Configuration Examples
- 33-SSH Configuration Examples
- 34-IP Source Guard Configuration Examples
- 35-Ethernet OAM Configuration Examples
- 36-CFD Configuration Examples
- 37-DLDP Configuration Examples
- 38-VRRP Configuration Examples
- 39-BFD Configuration Examples
- 40-NTP Configuration Examples
- 41-SNMP Configuration Examples
- 42-NQA Configuration Examples
- 43-Mirroring Configuration Examples
- 44-sFlow Configuration Examples
- 45-OpenFlow Configuration Examples
- 46-MAC Address Table Configuration Examples
- 47-Static Multicast MAC Address Entry Configuration Examples
- 48-IP Unnumbered Configuration Examples
- 49-Congestion Avoidance and Queue Scheduling Configuration Examples
- 50-Attack Protection Configuration Examples
- 51-Smart Link Configuration Examples
- 52-RRPP Configuration Examples
- 53-BGP Route Selection Configuration Examples
- 54-IS-IS Route Summarization Configuration Examples
- 55-MPLS OAM Configuration Examples
- 56-MPLS TE Configuration Examples
- 57-VXLAN Configuration Examples
- 58-NetStream Configuration Examples
- 59-EVPN-DCI over an MPLS L3VPN Network Configuration Examples
- 60-PTP Configuration Examples
- 61-S-MLAG Configuration Examples
- 62-MPLS SR Configuration Examples
- 63-Puppet Configuration Examples
- Related Documents
-
Title | Size | Download |
---|---|---|
04-Ethernet Link Aggregation Configuration Examples | 94.90 KB |
|
H3C S12500R Switch Router Series |
Ethernet Link Aggregation |
Configuration Examples |
Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.
No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.
Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.
The information in this document is subject to change without notice.
Contents
Example: Configuring Layer 2 link aggregation
Example: Configuring Layer 3 link aggregation
Introduction
This document provides Ethernet link aggregation configuration examples.
Prerequisites
The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.
This document assumes that you have basic knowledge of Ethernet link aggregation.
Example: Configuring Layer 2 link aggregation
Network configuration
As shown in Figure 1, both Device A and Device B forward traffic from VLAN 10 and VLAN 20.
Configure link aggregation on Device A and Device B to meet the following requirements:
· VLAN 10 on Device A can communicate with VLAN 10 on Device B.
· VLAN 20 on Device A can communicate with VLAN 20 on Device B.
Analysis
To enable traffic from VLAN 10 and VLAN 20 to pass through Layer 2 aggregate interface Bridge-aggregation 1, perform the following tasks:
· Configure Layer 2 aggregate interface Bridge-aggregation 1 as a trunk port.
· Assign the aggregate interface to VLAN 10 and VLAN 20.
Software versions used
This configuration example was created and verified on Release 3606.
Restrictions and guidelines
When you configure Layer 2 link aggregation, follow these restrictions and guidelines:
· When you assign a port to an aggregation group, the recommended configuration procedure is as follows:
a. Use the display this command in interface view to check the following attribute configurations of the port:
- Port isolation.
- VLAN.
- VLAN mapping.
b. If any of the above configurations exist, use the undo forms of the corresponding commands to remove these configurations. This enables the port to use the default attribute configurations.
c. Assign the port to the aggregation group.
· In a static aggregation group, the Selected state of a port is not affected by whether the peer port is added to an aggregation group and is Selected. As a result, the Selected state of a port might be different from the Selected state of the peer port. When both ends support static aggregation and dynamic aggregation, use dynamic aggregation.
Procedures
1. Configure Device A:
# Create VLAN 10, and assign port HundredGigE 1/0/4 to VLAN 10.
<DeviceA> system-view
[DeviceA] interface hundredgige 1/0/4
[DeviceA-HundredGigE1/0/4] port link-mode bridge
[DeviceA-HundredGigE1/0/4] quit
[DeviceA] vlan 10
[DeviceA-vlan10] port hundredgige 1/0/4
[DeviceA-vlan10] quit
# Create VLAN 20, and assign port HundredGigE 1/0/5 to VLAN 20.
[DeviceA] interface hundredgige 1/0/5
[DeviceA-HundredGigE1/0/5] port link-mode bridge
[DeviceA-HundredGigE1/0/5] quit
[DeviceA] vlan 20
[DeviceA-vlan20] port hundredgige 1/0/5
[DeviceA-vlan20] quit
# Create Layer 2 aggregate interface Bridge-aggregation 1. Use one of the following methods as needed.
¡ Use the static aggregation mode to create Layer 2 aggregate interface Bridge-aggregation 1.
[DeviceA] interface bridge-aggregation 1
[DeviceA-Bridge-Aggregation1] quit
¡ Use the dynamic aggregation mode to create Layer 2 aggregate interface Bridge-aggregation 1.
[DeviceA] interface bridge-aggregation 1
[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic
[DeviceA-Bridge-Aggregation1] quit
# Assign ports HundredGigE 1/0/1 through HundredGigE 1/0/3 to aggregation group 1.
[DeviceA] interface range hundredgige 1/0/1 to hundredgige 1/0/3
[DeviceA-if-range] port link-aggregation group 1
[DeviceA-if-range] quit
# Configure Layer 2 aggregate interface Bridge-aggregation 1 as a trunk port.
[DeviceA] interface bridge-aggregation 1
[DeviceA-Bridge-Aggregation1] port link-type trunk
Configuring HundredGigE1/0/1 done.
Configuring HundredGigE1/0/2 done.
Configuring HundredGigE1/0/3 done.
# Assign the aggregate interface to VLANs 10 and 20.
[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10 20
Configuring HundredGigE1/0/1 done.
Configuring HundredGigE1/0/2 done.
Configuring HundredGigE1/0/3 done.
[DeviceA-Bridge-Aggregation1] quit
2. Configure Device B in the same way Device A is configured. (Details not shown.)
Verifying the configuration
# Display detailed information about the link aggregation groups on Device A.
· Link aggregation configuration information when the static aggregation mode is used:
[DeviceA] display link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I -- Individual
Port: A -- Auto port
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H -- Expired
Role: P -- Primary, S -- Secondary
Aggregation Interface: Bridge-Aggregation1
Aggregation Mode: Static
Loadsharing Type: Shar
Port Status Priority Oper-Key Role
HGE1/0/1 S 32768 1 None
HGE1/0/2 S 32768 1 None
HGE1/0/3 S 32768 1 None
The output shows that all member ports in the local aggregation group are in the Selected state. The Selected states of the local member ports are not affected by the Selected states of the peer member ports.
· Link aggregation configuration information when the dynamic aggregation mode is used:
[DeviceA] display link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I -- Individual
Port: A -- Auto port
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H -- Expired
Role: P -- Primary, S -- Secondary
Aggregation Interface: Bridge-Aggregation1
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 000f-e234-5678
Local:
Port Status Priority Index Oper-Key Flag
HGE1/0/1 S 32768 2 1 {ACDEF}
HGE1/0/2 S 32768 3 1 {ACDEF}
HGE1/0/3 S 32768 4 1 {ACDEF}
Remote:
Actor Priority Index Oper-Key SystemID Flag
HGE1/0/1 32768 2 1 0x8000, a4e5-c316-0100 {ACDEF}
HGE1/0/2 32768 3 1 0x8000, a4e5-c316-0100 {ACDEF}
HGE1/0/3 32768 4 1 0x8000, a4e5-c316-0100 {ACDEF}
The output shows that the local member ports and the corresponding peer member ports are all Selected. In the dynamic link aggregation mode, each local member port and its peer member port have the same Selected state through exchanging LACPDUs. The user data traffic can be forwarded correctly.
Configuration files
· Device A:
#
vlan 10
#
interface HundredGigE1/0/4
port link-mode bridge
port access vlan 10
#
vlan 20
#
interface HundredGigE1/0/5
port link-mode bridge
port access vlan 20
¡ In the static aggregation mode:
#
interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan 10 20
¡ In the dynamic aggregation mode:
#
interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan 10 20
link-aggregation mode dynamic
#
interface HundredGigE1/0/1
port link-mode bridge
port link-type trunk
port trunk permit vlan 10 20
port link-aggregation group 1
#
interface HundredGigE1/0/2
port link-mode bridge
port link-type trunk
port trunk permit vlan 10 20
port link-aggregation group 1
#
interface HundredGigE1/0/3
port link-mode bridge
port link-type trunk
port trunk permit vlan 10 20
port link-aggregation group 1
#
· Device B:
The configuration file on Device B is the same as the configuration file on Device A.
Example: Configuring Layer 3 link aggregation
Network configuration
On the network as shown in Figure 2, perform the following tasks:
· Configure a Layer 3 dynamic aggregation group on both Device A and Device B.
· Configure IP addresses and subnet masks for the corresponding Layer 3 aggregate interfaces.
Software versions used
This configuration example was created and verified on Release 3606.
Restrictions and guidelines
In a static aggregation group, the Selected state of a port is not affected by whether the peer port is added to an aggregation group and is Selected. As a result, the Selected state of a port might be different from the Selected state of the peer port. When both ends support static aggregation and dynamic aggregation, use dynamic aggregation.
Procedures
# Create Layer 3 aggregate interface Route-Aggregation 1. Use one of the following methods as needed.
¡ Use the static aggregation mode to create Layer 3 aggregate interface Route-Aggregation 1.
<DeviceA> system-view
[DeviceA] interface route-aggregation 1
¡ Use the dynamic aggregation mode to create Layer 3 aggregate interface Route-Aggregation 1.
[DeviceA] interface route-aggregation 1
[DeviceA-Route-Aggregation1] link-aggregation mode dynamic
# Configure an IP address and subnet mask for Layer 3 aggregate interface Route-Aggregation 1.
[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24
[DeviceA-Route-Aggregation1] quit
# Assign ports HundredGigE 1/0/1 through HundredGigE 1/0/3 to aggregation group 1.
[DeviceA] interface range hundredgige 1/0/1 to hundredgige 1/0/3
[DeviceA-if-range] port link-mode route
[DeviceA-if-range] port link-aggregation group 1
[DeviceA-if-range] quit
2. Configure Device B in the same way Device A is configured. (Details not shown.)
Verifying the configuration
# Display detailed information about the link aggregation groups on Device A.
· Link aggregation configuration information when the static aggregation mode is used:
[DeviceA] display link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I -- Individual
Port: A -- Auto port
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H – Expired
Role: P -- Primary, S -- Secondary
Aggregate Interface: Route-Aggregation1
Aggregation Mode: Static
Loadsharing Type: Shar
Port Status Priority Oper-Key Role
HGE1/0/1 S 32768 1 None
HGE1/0/2 S 32768 1 None
HGE1/0/3 S 32768 1 None
The output shows that all member ports in the local aggregation group are in Selected state. The Selected states of the local member ports are not affected by the Selected states of the peer member ports.
· Link aggregation configuration information when the dynamic aggregation mode is used:
[DeviceA] display link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I -- Individual
Port: A -- Auto port
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H -- Expired
Aggregate Interface: Route-Aggregation1
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 000f-e267-6c6a
Local:
Port Status Priority Index Oper-Key Flag
HGE1/0/1 S 32768 2 1 {ACDEF}
HGE1/0/2 S 32768 3 1 {ACDEF}
HGE1/0/3 S 32768 4 1 {ACDEF}
Remote:
Actor Priority Index Oper-Key SystemID Flag
HGE1/0/1 32768 2 1 0x8000, 68fa-34f2-0200 {ACDEF}
HGE1/0/2 32768 3 1 0x8000, 68fa-34f2-0200 {ACDEF}
HGE1/0/3 32768 4 1 0x8000, 68fa-34f2-0200 {ACDEF}
The output shows that the local member ports and the corresponding peer member ports are all Selected. In the dynamic link aggregation mode, each local member port and its peer member port have the same Selected state through exchanging LACPDUs. The user data traffic can be forwarded correctly.
Configuration files
· Device A:
#
¡ In the static aggregation mode:
#
interface route-aggregation1
ip address 192.168.1.1 255.255.255.0
#
¡ In the dynamic aggregation mode:
#
interface route-aggregation1
ip address 192.168.1.1 255.255.255.0
link-aggregation mode dynamic
#
interface HundredGigE1/0/1
port link-mode route
port link-aggregation group 1
#
interface HundredGigE1/0/2
port link-mode route
port link-aggregation group 1
#
interface HundredGigE1/0/3
port link-mode route
port link-aggregation group 1
#
Device B:
The configuration file on Device B is similar as the configuration file on Device A.
Related documentation
· H3C S12500R Switch Router Series Layer 2—LAN Switching Configuration Guide-R3606
· H3C S12500R Switch Router Series Layer 2—LAN Switching Command Reference-R3606